ubuntu apt

问题

1
2
3
4
5
6
7
8
9
Reading package lists... Error!
W: GPG error: http://download.opensuse.org Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY D54CC349F42D5F07
E: Encountered a section with no Package: header
E: Problem with MergeList /var/lib/apt/lists/packages.linuxmint.com_dists_qiana_import_i18n_Translation-en
E: The package lists or status file could not be parsed or opened.
Reading package lists... Error!
E: Encountered a section with no Package: header
E: Problem with MergeList /var/lib/apt/lists/packages.linuxmint.com_dists_qiana_import_i18n_Translation-en
E: The package lists or status file could not be parsed or opened.

解决方法

1
2
3
(workspace) ➜ ~ apt-key list | grep "expired:"
(workspace) ➜ ~ apt-key adv --recv-keys --keyserver keys.gnupg.net "C300EE8C"
(workspace) ➜ ~ apt-key adv --recv-keys --keyserver keys.gnupg.net "7BD9BF62"